SMS Delivery Issues
Incident Report for Duo Security
Resolved
We have resolved the issues with our SMS provider.
Posted 11 months ago. Jan 06, 2018 - 11:29 EST
Monitoring
We are seeing signs that SMS delivery is now working properly for all customers and are monitoring the issue to ensure it doesn't recur.
Posted 11 months ago. Jan 06, 2018 - 10:36 EST
Update
Some Verizon customers are continuing to experience issues receiving SMS messages generated by the Duo service. We've confirmed that this Verizon issue is not specific to Duo. We're continuing to work with our telephony providers to resolve these issues.
Posted 11 months ago. Jan 06, 2018 - 09:55 EST
Update
We are seeing signs that SMS delivery is now working properly for most customers. Some SMS messages to Verizon phone numbers are still not being delivered in a timely fashion. We are working with our providers to seek resolution for this issue.
Posted 11 months ago. Jan 06, 2018 - 08:33 EST
Identified
We have identified an issue with one of our primary SMS providers, and have begun routing messages to a fallback provider.
Posted 11 months ago. Jan 06, 2018 - 07:30 EST