SMS Delivery Issues
Incident Report for Duo Security
Resolved
We have resolved the issues with our SMS provider.
Posted 12 months ago. Mar 02, 2018 - 14:40 EST
Monitoring
SMS messages generated by the Duo service are now being delivered promptly. We are actively monitoring to ensure the issue does not reoccur.
Posted 12 months ago. Mar 02, 2018 - 12:55 EST
Investigating
We have identified an issue causing SMS messages generated by Duo services to be delayed. We are working with our SMS providers to resolve the issue.
Posted 12 months ago. Mar 02, 2018 - 11:35 EST