SMS Delivery Delays
Incident Report for Duo Security
Resolved
The SMS delivery issues have been resolved.
Posted 11 months ago. Jan 04, 2018 - 15:27 EST
Monitoring
All SMS messages are now being delivered in a timely fashion. We are monitoring the issue to ensure it doesn't reoccur.
Posted 11 months ago. Jan 04, 2018 - 12:19 EST
Identified
We have identified an issue causing SMS messages generated by Duo services to be delayed. We are working with our SMS providers to resolve the issue.
Posted 11 months ago. Jan 04, 2018 - 12:13 EST