All Deployments: UK and India SMS delivery failure
Incident Report for Duo
Resolved
The issue with SMS delivery for all countries except US and Canada is now confirmed to be fully resolved.
Posted May 30, 2022 - 11:39 EDT
Monitoring
After further investigation, we've detected additional failures for SMS delivery for all countries except US and Canada. We are working to correct this as soon as possible.
Posted May 30, 2022 - 09:52 EDT
Investigating
After further investigation, we've detected additional failures for SMS delivery for all countries except USA and Canada. We are working to correct this as soon as possible.
Posted May 30, 2022 - 09:23 EDT
Monitoring
We are now monitoring SMS and Call delivery after experiencing service improvements and will update this page in case of new information or developments.
Posted May 30, 2022 - 08:43 EDT
Investigating
We are currently experiencing SMS delivery failures in UK and India affecting all deployments. We are working to correct the issue as soon as possible.

Please check back here or subscribe to updates for any changes.
Posted May 30, 2022 - 08:39 EDT
This incident affected: DUO48 (SMS Message Delivery), DUO51 (SMS Message Delivery), DUO23 (SMS Message Delivery), DUO36 (SMS Message Delivery), DUO21 (SMS Message Delivery), DUO57 (SMS Message Delivery), DUO10 (SMS Message Delivery), DUO49 (SMS Message Delivery), DUO15 (SMS Message Delivery), DUO7 (SMS Message Delivery), DUO20 (SMS Message Delivery), DUO37 (SMS Message Delivery), DUO18 (SMS Message Delivery), DUO13 (SMS Message Delivery), DUO6 (SMS Message Delivery), DUO41 (SMS Message Delivery), DUO16 (SMS Message Delivery), DUO5 (SMS Message Delivery), DUO2 (SMS Message Delivery), DUO24 (SMS Message Delivery), DUO32 (SMS Message Delivery), DUO43 (SMS Message Delivery), DUO58 (SMS Message Delivery), DUO40 (SMS Message Delivery), DUO8 (SMS Message Delivery), DUO50 (SMS Message Delivery), DUO3 (SMS Message Delivery), DUO27 (SMS Message Delivery), DUO60 (SMS Message Delivery), DUO66 (SMS Message Delivery), DUO46 (SMS Message Delivery), DUO65 (SMS Message Delivery), DUO25 (SMS Message Delivery), DUO64 (SMS Message Delivery), DUO12 (SMS Message Delivery), DUO44 (SMS Message Delivery), DUO26 (SMS Message Delivery), DUO30 (SMS Message Delivery), DUO14 (SMS Message Delivery), DUO63 (SMS Message Delivery), DUO9 (SMS Message Delivery), DUO55 (SMS Message Delivery), DUO19 (SMS Message Delivery), DUO34 (SMS Message Delivery), DUO38 (SMS Message Delivery), DUO11 (SMS Message Delivery), DUO54 (SMS Message Delivery), DUO4 (SMS Message Delivery), DUO62 (SMS Message Delivery), DUO31 (SMS Message Delivery), DUO42 (SMS Message Delivery), DUO45 (SMS Message Delivery), DUO17 (SMS Message Delivery), DUO53 (SMS Message Delivery), DUO22 (SMS Message Delivery), DUO47 (SMS Message Delivery), DUO33 (SMS Message Delivery), DUO59 (SMS Message Delivery), DUO61 (SMS Message Delivery), DUO56 (SMS Message Delivery), DUO28 (SMS Message Delivery), DUO29 (SMS Message Delivery), DUO39 (SMS Message Delivery), DUO52 (SMS Message Delivery), DUO1 (SMS Message Delivery), and DUO35 (SMS Message Delivery).