External Internet Provider Issue
Incident Report for Duo Security
Resolved
We believe the internet provider has resolved the issue and connectivity should be restored soon.
Posted over 2 years ago. Jun 30, 2015 - 21:16 EDT
Investigating
We are currently monitoring an external Internet provider issue that is preventing some users from connecting to Duo.
Posted over 2 years ago. Jun 30, 2015 - 21:10 EDT