Difficulty reaching primary Duo Technical Support line
Incident Report for Duo Security
Resolved
We've resolved the issue with our telephony providers and our main support numbers are confirmed to be working again from previously failing numbers.
Posted 10 months ago. Feb 22, 2018 - 19:01 EST
Investigating
We are currently investigating issues with reaching the primary Duo Technical Support line from multiple mobile providers.

Please note that this is not affecting Duo Admin Panel or two-factor authentication telephony in any way.

For the time being, please contact support via email, chat, or directly at +1 734-822-6416.
Posted 10 months ago. Feb 22, 2018 - 09:25 EST