Duo Support Email Support System Issue
Incident Report for Duo
Resolved
The issues regarding the creation of cases emailed to Duo Support is now fully resolved.
Posted Feb 25, 2022 - 03:39 EST
Monitoring
The issue is resolved and the support ticket portal is available again. We are monitoring to ensure no recurrence of the behaviour.
Posted Feb 25, 2022 - 02:22 EST
Investigating
Duo Support is currently investigating an issue disrupting the creation of cases emailed to Duo Support.
We are working with the appropriate teams to address the core issue.
If you need to contact Duo Support, we recommend contacting us via phone for critical needs or less urgent matters.
Posted Feb 25, 2022 - 01:45 EST
This incident affected: Duo Support (Email Support).