Admin Panel Billing page not functional
Incident Report for Duo Security
Resolved
The Duo Admin Panel Billing page is now functioning properly.
Posted about 1 month ago. Feb 15, 2017 - 14:25 EDT
Identified
The Duo Admin Panel Billing page is currently failing to load. We are working with an upstream vendor to resolve the issue. Authentication services and other aspects of the Admin Panel are unaffected. Thank you for your patience as we work through this issue.
Posted about 1 month ago. Feb 15, 2017 - 11:33 EDT