Telephony Issues
Incident Report for Duo Security
Resolved
We have resolved the issue with our telephony provider.
Posted over 2 years ago. Oct 15, 2014 - 00:57 EDT
Identified
We have identified an issue with one of our primary telephony providers, and have begun routing calls to a fallback provider.
Posted over 2 years ago. Oct 15, 2014 - 00:44 EDT
Investigating
We are investigating reports that our system is failing to complete outgoing phone calls.
Posted over 2 years ago. Oct 15, 2014 - 00:25 EDT