duo.com website issues
Incident Report for Duo Security
Resolved
The issue affecting the https://duo.com website has been resolved and the site is now performing as expected.
Posted 11 months ago. Jan 04, 2017 - 09:20 EST
Identified
We have identified an issue affecting the https://duo.com website and are working to resolve the underlying cause. Duo's Core Authentication Services including the Admin Panel, Push Delivery, and Telephony are not affected. Account administrators can continue to log in via https://admin.duosecurity.com or other account specific Admin Panel URLs.
Posted 11 months ago. Jan 04, 2017 - 09:09 EST