Duo Admin Panel Performance Issues
Incident Report for Duo Security
Resolved
The DUO41 Admin Panel is now performing as expected.
Posted about 1 year ago. Nov 09, 2016 - 11:28 EST
Monitoring
We have taken action to increase performance for the DUO41 Admin Panel and continue to monitor the system to ensure that the root cause of the earlier performance degradation has been completely resolved.
Posted about 1 year ago. Nov 09, 2016 - 11:09 EST
Identified
We have identified the underlying cause for Admin Panel performance degradation on DUO41. Duo's operations team is working diligently to restore performance for affected users.
Posted about 1 year ago. Nov 09, 2016 - 11:00 EST
Investigating
We are investigating reports that some DUO41 customers are experiencing performance issues while interacting with the Duo Admin Panel.
Posted about 1 year ago. Nov 09, 2016 - 10:56 EST
This incident affected: DUO41 (Admin Panel).