Duo Signup Page Issue
Incident Report for Duo
Resolved
New account signups via https://signup.duo.com/ continue to work as expected.
Posted Mar 14, 2017 - 17:15 EDT
Monitoring
We have implemented a fix that has restored new account signup functionality via https://signup.duo.com/. Our team will continue to monitor the situation to ensure continued stability of this service.
Posted Mar 14, 2017 - 11:33 EDT
Update
We continue to work with our provider to restore new account signup functionality. All other Duo services, including authentication, remain unaffected.
Posted Mar 14, 2017 - 08:03 EDT
Identified
We have identified an issue with one of our infrastructure providers which is preventing new Duo accounts from being created via https://signup.duo.com/. Existing accounts and all other Duo services are not affected. We are actively investigating options to restore new account signup functionality.
Posted Mar 14, 2017 - 06:24 EDT
Investigating
We are currently investigating an issue with our signup page.
Posted Mar 14, 2017 - 06:04 EDT