Phone Support Handling Issue
Incident Report for Duo
Resolved
Support phone call connectivity issues have been resolved.
All support calls are operational.
Posted Mar 23, 2022 - 02:01 EDT
Monitoring
Support phone call connectivity issues have been resolved and we are currently monitoring for stability.

Please subscribe to the status page for further updates.
Posted Mar 22, 2022 - 23:07 EDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 22, 2022 - 23:03 EDT
Identified
Our phone service provider is currently investigating the issue. Updates will be provided as they become available.
Posted Mar 22, 2022 - 20:47 EDT
Investigating
Duo Support is currently investigating an issue disrupting call connectivity between customers and our Support Engineers. We are working with the appropriate teams to address the core issue.
If you need to contact Duo Support, we recommend contacting us via the Support Ticket Portal or email for less urgent matters.
Posted Mar 22, 2022 - 20:29 EDT
This incident affected: Duo Support (Phone Support).