All Deployments: SMS delivery issues to Philippine (+63) phone numbers
Incident Report for Duo
Postmortem

SMS Failures to the Philippines - All Deployments

Incident Report - 2020-03-30

Summary

At 08:50 PM EDT on Monday, March 30, 2020, Duo became aware of issues delivering SMS messages to phone numbers located in the Philippines. After investigating the issue, Duo initiated a failover to a backup telephony provider restoring SMS delivery to the region.

Details

Duo uses telephony providers to send SMS to customers for authentications and enrollments. On March 30, 2020, one of Duo’s providers experienced issues sending SMS to numbers located in the Philippines.

Duo’s Engineering organization learned about an issue at 08:50 PM EDT. After identifying the scope of impact, the team failed over to a backup telephony provider at 09:10 PM EDT restoring full SMS delivery to the region. Simultaneously, the team worked with the failing provider to identify a root cause and resolve the issue.

Posted Mar 31, 2020 - 16:35 EDT

Resolved
We have confirmed that the issues with SMS delivery to the +63 country code are now fully resolved.
Posted Mar 31, 2020 - 16:34 EDT
Update
A fix has been implemented where SMS delivery has been rerouted.
We are monitoring the results with our backup provider.

Please check back here or subscribe to updates for any changes.
Posted Mar 30, 2020 - 22:08 EDT
Monitoring
A fix has been implemented where SMS delivery has been rerouted.
We are monitoring the results with our backup provider.

Please check back here or subscribe to updates for any changes.
Posted Mar 30, 2020 - 22:04 EDT
Investigating
We are currently investigating an issue with SMS deliveries to Philippine (+63) phone numbers on all of our deployments and are working to correct the issue as soon as possible.

All other authentication factors work as per usual (phone call, Duo Push, U2F, hardware token, etc.)

Please check back here or subscribe to updates for any changes.
Posted Mar 30, 2020 - 21:19 EDT
This incident affected: DUO49 (SMS Message Delivery), DUO36 (SMS Message Delivery), DUO52 (SMS Message Delivery), DUO59 (SMS Message Delivery), DUO31 (SMS Message Delivery), DUO56 (SMS Message Delivery), DUO57 (SMS Message Delivery), DUO15 (SMS Message Delivery), DUO46 (SMS Message Delivery), DUO43 (SMS Message Delivery), DUO58 (SMS Message Delivery), DUO4 (SMS Message Delivery), DUO20 (SMS Message Delivery), DUO23 (SMS Message Delivery), DUO8 (SMS Message Delivery), DUO25 (SMS Message Delivery), DUO61 (SMS Message Delivery), DUO50 (SMS Message Delivery), DUO51 (SMS Message Delivery), DUO38 (SMS Message Delivery), DUO3 (SMS Message Delivery), DUO27 (SMS Message Delivery), DUO30 (SMS Message Delivery), DUO16 (SMS Message Delivery), DUO42 (SMS Message Delivery), DUO10 (SMS Message Delivery), DUO12 (SMS Message Delivery), DUO34 (SMS Message Delivery), DUO41 (SMS Message Delivery), DUO21 (SMS Message Delivery), DUO45 (SMS Message Delivery), DUO53 (SMS Message Delivery), DUO6 (SMS Message Delivery), DUO13 (SMS Message Delivery), DUO17 (SMS Message Delivery), DUO18 (SMS Message Delivery), DUO22 (SMS Message Delivery), DUO37 (SMS Message Delivery), DUO7 (SMS Message Delivery), DUO60 (SMS Message Delivery), DUO47 (SMS Message Delivery), DUO19 (SMS Message Delivery), DUO1 (SMS Message Delivery), DUO33 (SMS Message Delivery), DUO5 (SMS Message Delivery), DUO55 (SMS Message Delivery), DUO26 (SMS Message Delivery), DUO63 (SMS Message Delivery), DUO44 (SMS Message Delivery), DUO14 (SMS Message Delivery), DUO39 (SMS Message Delivery), DUO48 (SMS Message Delivery), DUO32 (SMS Message Delivery), DUO29 (SMS Message Delivery), DUO24 (SMS Message Delivery), DUO2 (SMS Message Delivery), DUO28 (SMS Message Delivery), DUO65 (SMS Message Delivery), DUO9 (SMS Message Delivery), DUO54 (SMS Message Delivery), DUO40 (SMS Message Delivery), DUO64 (SMS Message Delivery), DUO62 (SMS Message Delivery), DUO11 (SMS Message Delivery), and DUO35 (SMS Message Delivery).