Microsoft Azure Service Outage
Incident Report for Duo Security
Resolved
Microsoft is reporting that all Azure Services are now functioning normally.
Posted 3 months ago. Sep 07, 2018 - 10:28 EDT
Update
Microsoft Azure Engineers have restored access to the majority of services, and most customers should be seeing signs of recovery.

Please keep an eye on the Azure status website for the further updates on this issue. https://azure.microsoft.com/en-gb/status/
Posted 3 months ago. Sep 05, 2018 - 18:56 EDT
Update
Microsoft Azure Engineers have restored access to the majority of services, and most customers should be seeing signs of recovery.

Please keep an eye on the Azure status website for the further updates on this issue. https://azure.microsoft.com/en-gb/status/
Posted 3 months ago. Sep 05, 2018 - 11:49 EDT
Identified
Microsoft Azure has reported an outage with their South Central US region. Azure instances in this region may experience failures with Duo's Azure Conditional Access integrations at minimum, but all components of the tenant may be unreachable.

Azure Active Directory may also experience intermittent issues across all Azure regions.

Please keep an eye on the Azure status website for the most recent updates about this issue. https://azure.microsoft.com/en-gb/status/
Posted 3 months ago. Sep 04, 2018 - 09:05 EDT