Duo Support Phone Call Issues
Incident Report for Duo
Resolved
Support phone call connectivity issues have been resolved.
All support calls are operational.
Posted Apr 07, 2022 - 21:20 EDT
Monitoring
Support phone call connectivity issues have been resolved and we are currently monitoring for stability.

Please subscribe to the status page for further updates.
Posted Apr 07, 2022 - 18:52 EDT
Identified
Our phone service provider is currently investigating the issue.
Updates will be provided as they become available.
Posted Apr 07, 2022 - 17:43 EDT
Investigating
Duo Support is currently investigating an issue disrupting call connectivity between some customers and our Technical Support Engineers. We are working with the appropriate teams to address the core issue.

If you need to contact Duo Support, we recommend contacting us via email for less urgent matters.
Posted Apr 07, 2022 - 16:44 EDT
This incident affected: Duo Support (Phone Support).