[Multiple Deployments] Duo Authentication Failures

Incident Report for Duo

Resolved

Duo Authentications continue to be successful and all services are fully operational. This incident is resolved.
Posted Sep 18, 2024 - 11:47 EDT

Monitoring

After continuous testing on our side, we are confident that the issues experienced were caused by external factors. We are continuing to monitor for any potential uptick in failure rates for Duo Authentication and will provide updates when available.
Posted Sep 18, 2024 - 10:59 EDT

Investigating

We are investigating an issue causing degraded performance of authentications across multiple Duo deployments and are working to correct the issue as soon as possible.

Please check back here or subscribe to updates for any changes.
Posted Sep 18, 2024 - 09:38 EDT