Duo Support Phone System Issue
Incident Report for Duo
Resolved
The issue with call handling for our Duo Support Team has been resolved.
Posted Jul 31, 2024 - 12:56 EDT
Monitoring
We have deployed a fix for the issue with call handling for our Duo Support Team and are monitoring the results.
Posted Jul 31, 2024 - 12:45 EDT
Identified
We have identified the issues with call handling for our Duo Support Team and are working to deploy a fix.

If you need to submit a case, please utilize the Duo Support Portal or send us an email to support@duo.com
Posted Jul 31, 2024 - 12:35 EDT
Investigating
We are currently investigating an issue with call handling for our Duo Support Team.

If you need to submit a case, please utilize the Duo Support Portal or send us an email to support@duo.com

Please check back here or subscribe to updates for any changes.
Posted Jul 31, 2024 - 12:14 EDT
This incident affected: Duo Support (Phone Support).