Multiple Deployments: Admin Panel Log Delays for Some Customers
Incident Report for Duo
Postmortem

Summary

On January 7, 2025, Duo's Engineering Team mitigated a log delay for certain admin panel users. The root cause was identified an incorrect software deployment.

The issue was resolved on the same day by deploying the correct version of software for activity and telephony logs.

Details

During our regular patch cycle, an incorrect version of the software was inadvertently pushed to the production instances. The issue was quickly identified, and the team immediately rectified it by deploying the correct version to the newly patched instances. The response aimed to minimize potential impact and ensure that the correct functionality was restored without significant downtime.

Multiple teams worked together to ensure the integrity of the deployments and restore system stability. We promptly triaged the environment to identify affected deployments and pushed the correct software versions to each one. After deploying the updates, we conducted thorough verification to ensure both the correct software version and the appropriate patch version were in place.

The patching process is currently in its final evolution phase following our recent transition to Auto Scaling Groups (ASGs). Moving forward, each team will be responsible for managing their deployments patching to minimize external interference with their regular release schedules, which occur at least every two weeks and thus still adhere to our compliance guidelines on vulnerability management. This approach will streamline operations and ensure greater autonomy for teams while maintaining system stability.

Posted Jan 10, 2025 - 10:53 EST

Resolved
The issue impacting the availability of Activity and Telephony Log messages in the Admin Panel / Admin API is now resolved and full functionality has been restored.
Posted Jan 07, 2025 - 22:06 EST
Monitoring
We have implemented a fix for the issue impacting the availability of Activity and Telephony Log messages in the Admin Panel / Admin API. We will continue to monitor and post any updates when the incident is considered fully resolved.
Posted Jan 07, 2025 - 20:57 EST
Identified
We have identified the issue impacting the availability of Activity and Telephony Log messages in the Admin Panel / Admin API and are working to deploy a fix.
Posted Jan 07, 2025 - 18:52 EST
Investigating
We are currently investigating an issue that is impacting the availability of Activity and Telephony Log messages for the following deployments below. This impacts the Admin Panel and Admin API:
DUO9
DUO17
DUO22
DUO39
DUO40
DUO42
DUO45
DUO50
DUO52
DUO55
DU056
DUO58
DUO61
DU062
DU063
DU064
DU065
DU072
DUO73
DUO74
DU075
DUO76
DUO77
DUO78
Authentication and all other functionality is operational. We are actively working toward resolving this issue, and will provide further details as soon as they are available.
Posted Jan 07, 2025 - 18:22 EST
This incident affected: DUO17 (Admin Panel), DUO22 (Admin Panel), DUO39 (Admin Panel), DUO40 (Admin Panel), DUO42 (Admin Panel), DUO45 (Admin Panel), DUO9 (Admin Panel), DUO50 (Admin Panel), DUO52 (Admin Panel), DUO55 (Admin Panel), DUO56 (Admin Panel), DUO58 (Admin Panel), DUO61 (Admin Panel), DUO62 (Admin Panel), DUO63 (Admin Panel), DUO64 (Admin Panel), DUO65 (Admin Panel), DUO72 (Admin Panel), DUO73 (Admin Panel), DUO74 (Admin Panel), DUO75 (Admin Panel), DUO76 (Admin Panel), DUO77 (Admin Panel), and DUO78 (Admin Panel).