Duo Support Phone System Issue

Incident Report for Duo

Resolved

We have resolved the issue impacting the support phone number listed on duo.com/support.
Posted Jul 24, 2024 - 11:40 EDT

Identified

We have identified the issue with reachability to the phone number listed on Duo's Support Page and are working towards a resolution. As a workaround, please use the phone number found in your Duo Admin Panel under the Help menu in the top right corner of the page.
Posted Jul 24, 2024 - 10:15 EDT

Investigating

We are currently investigating an issue with reachability to the phone number listed on Duo's Support Page. As a workaround, please use the phone number found in your Duo Admin Panel under the Help menu in the top right corner of the page.
Posted Jul 24, 2024 - 09:46 EDT
This incident affected: Duo Support (Phone Support).