Service degradation on DUO81

Incident Report for Duo

Resolved

The issue was resolved by rerouting traffic.
Posted Mar 01, 2026 - 11:39 EST

Monitoring

We have rerouted traffic and are monitoring the behavior for stable, positive results.
Posted Mar 01, 2026 - 11:09 EST

Update

We are continuing to work to reroute traffic in order to alleviate the degraded performance.
Posted Mar 01, 2026 - 10:33 EST

Identified

We have isolated the issue to a regional outage and are rerouting our traffic to alleviate the degraded performance.
Posted Mar 01, 2026 - 09:13 EST

Investigating

We are currently investigating a service degradation on our DUO81 deployment and are working to restore services as soon as possible.
Posted Mar 01, 2026 - 08:29 EST
This incident affected: DUO81 (Core Authentication Service, Admin Panel, Push Delivery, Phone Call Delivery, SMS Message Delivery, Cloud PKI, SSO).