[Multiple Deployments] Authentication Delays for Duo SSO Logins using Active Directory

Incident Report for Duo

Resolved

After continued monitoring, we can confirm that the issue causing intermittent authentication delays for Duo SSO logins using Active Directory, affecting a small subset of customers, has been resolved.
Posted May 19, 2025 - 09:46 EDT

Monitoring

We have identified that the issue causing intermittent authentication delays for Duo SSO logins using Active Directory affected a small subset of customers and has since resolved as it was caused by outside factors.

We are continuing to monitor for any further delays at this time.
Posted May 19, 2025 - 09:19 EDT

Update

We are currently investigating an issue causing intermittent authentication delays for Duo SSO logins using Active Directory as an authentication source.

Please check back here or subscribe to updates for any changes.
Posted May 19, 2025 - 08:30 EDT

Investigating

We are currently investigating an issue causing intermittent authentication delays for Duo SSO logins using Active Directory as an authentication source.

Please check back here or subscribe to updates for any changes.
Posted May 19, 2025 - 08:24 EDT
This incident affected: DUO1 (SSO), DUO2 (SSO), DUO4 (SSO), DUO6 (SSO), DUO7 (SSO), DUO9 (SSO), DUO10 (SSO), DUO13 (SSO), DUO14 (SSO), DUO15 (SSO), DUO16 (SSO), DUO17 (SSO), DUO18 (SSO), DUO19 (SSO), DUO20 (SSO), DUO21 (SSO), DUO22 (SSO), DUO23 (SSO), DUO28 (SSO), DUO31 (SSO), DUO33 (SSO), DUO36 (SSO), DUO37 (SSO), DUO39 (SSO), DUO40 (SSO), DUO41 (SSO), DUO42 (SSO), DUO49 (SSO), DUO50 (SSO), DUO52 (SSO), DUO55 (SSO), DUO56 (SSO), DUO58 (SSO), DUO60 (SSO), DUO62 (SSO), DUO63 (SSO), DUO64 (SSO), DUO65 (SSO), DUO72 (SSO), DUO73 (SSO), DUO74 (SSO), DUO75 (SSO), DUO76 (SSO), DUO77 (SSO), DUO78 (SSO), DUO79 (SSO), DUO80 (SSO), and DUO35 (SSO).