DUO39: Issues Accessing Admin Panel
Incident Report for Duo
Postmortem

Issues Accessing the Duo Admin Panel - DUO39

Incident Report - 2020/05/13

Summary

On Wednesday, May 13, 2020 from 6:01 PM EST to 6:38 PM EDT, some customers were not able to access the Duo Admin Panel due to a configuration issue in a code release to the DUO39 deployment. The Duo Engineering Team fixed the issue and restored service at 6:38 PM EDT.

Details

On Wednesday, May 13, 2020 at 6:01 PM EDT, Duo received multiple reports from customers stating that they were unable to access the Admin Panel.

Duo’s Engineering team investigated the issue and determined that the Admin Panel was not properly communicating with a dependent service. They traced the origin of the problem to a code release for the DUO39 deployment that finished deploying at 6:01 PM. The team was able to fix the configuration issue and restore service at 6:38 PM.

Duo is committed to providing our customers a robust, highly available service. This issue typically would be caught by integration tests that are run during the code deployment process, and this issue exposed a bug in our integration test suite. That bug has been rectified and we have put measures in place to protect the availability of Duo’s service from similar incidents in the future.

Posted May 14, 2020 - 14:38 EDT

Resolved
The issue regarding Admin Panel access on the DUO39 deployment is fully resolved and all services are now fully functional.

We will be posting a root-cause analysis (RCA) here once our engineering team has finished its thorough investigation of the issue.

Please make sure to check back or subscribe to be notified when the RCA is posted.
Posted May 13, 2020 - 19:02 EDT
Monitoring
We have identified issues accessing the Duo Admin Panel for accounts on our DUO39 deployment. Affected accounts will have seen an "Oops... Looks like we're having some server issues." error when attempting to log in to the Duo Admin Panel.

Our engineering team successfully deployed a change to resolve this and we are continuing to monitor this.

User authentications are not impacted at this time.
Posted May 13, 2020 - 18:44 EDT
This incident affected: DUO39 (Admin Panel).