SMS delivery failure in United Kingdom
Incident Report for Duo
Resolved
After monitoring our internal systems we have confirmed that this issue seems to be related to cellular service provider disruptions. For further assistance on this, please consider contacting your cellular service provider.
Posted Jun 26, 2024 - 05:34 EDT
Monitoring
After investigating, we have determined that our services are fully operational, and some customers might be impacted by various outages from their respective service providers. Please check with your cellular service provider for further troubleshooting.
Posted Jun 26, 2024 - 04:43 EDT
Investigating
We are currently investigating an issue related to SMS delivery in United Kingdom. Please check back here or subscribe to updates for any changes.
Posted Jun 26, 2024 - 04:23 EDT