All Deployments: Phone Call Delivery Issues for T-Mobile Customers
Incident Report for Duo
Resolved
We have confirmed that phone authentication calls to T-Mobile users are no longer being marked as “Scam Likely” or blocked entirely. This issue, which potentially affected phone callback authentication from Duo’s default phone number across all Duo deployments, is now fully resolved.

Note that if you have set a custom Caller ID number in your Duo Admin Panel, you may continue to experience this issue until T-Mobile has whitelisted your specific number as well, so you may need to contact them to do so if you have not already. Learn more in this Knowledge Base article: http://help.duo.com/s/article/4150.
Posted 2 months ago. May 07, 2019 - 09:58 EDT
Monitoring
Our requests to whitelist our default numbers used for phone callback authentication have been approved and implemented, and we have reports from customers with T-Mobile users that calls are no longer being marked as “Scam Likely” nor blocked entirely.

Note that if you have set a custom Caller ID number in your Duo Admin Panel, you may continue to experience this issue until T-Mobile has whitelisted your specific number as well, so you may need to contact them to do so if you have not already. Learn more in this Knowledge Base article: http://help.duo.com/s/article/4150.

We will continue to monitor the issue and will post any updates when the incident is considered fully resolved.

Please check back here or subscribe here for further updates.
Posted 3 months ago. May 03, 2019 - 14:41 EDT
Identified
We have contacted T-Mobile and our telephony providers to request that all Duo numbers be whitelisted to resolve this issue. We will provide updates on this process as soon as possible.

In the meantime, please follow the steps listed in this Knowledge Base article to work around the issue for users that are affected:

https://help.duo.com/s/article/4150

Please check back here or subscribe to updates for any changes.
Posted 3 months ago. Apr 30, 2019 - 10:02 EDT
Investigating
We are currently investigating an issue causing phone calls sent to T-Mobile subscribers to either not arrive or to be marked as "Scam Likely" on the phone's Caller ID with phone callback authentication on all of our deployments and are working with our telephony providers to correct the issue as soon as possible.

There are currently two known workarounds for this issue:
1. Configure a different Outgoing Caller ID to use for phone callback authentication in the Duo Admin Panel -> Settings -> Phone Calls section
2. Have affected users reach out to their T-Mobile carrier to ensure that Duo's phone number or the Outgoing Caller ID set in the Duo Admin Panel is not being blocked

Please check back here or subscribe to updates for any changes.
Posted 3 months ago. Apr 29, 2019 - 21:07 EDT
This incident affected: DUO34 (Phone Call Delivery), DUO62 (Phone Call Delivery), DUO14 (Phone Call Delivery), DUO57 (Phone Call Delivery), DUO2 (Phone Call Delivery), DUO61 (Phone Call Delivery), DUO8 (Phone Call Delivery), DUO53 (Phone Call Delivery), DUO1 (Phone Call Delivery), DUO56 (Phone Call Delivery), DUO51 (Phone Call Delivery), DUO60 (Phone Call Delivery), DUO49 (Phone Call Delivery), DUO54 (Phone Call Delivery), DUO9 (Phone Call Delivery), DUO25 (Phone Call Delivery), DUO28 (Phone Call Delivery), DUO18 (Phone Call Delivery), DUO26 (Phone Call Delivery), DUO13 (Phone Call Delivery), DUO15 (Phone Call Delivery), DUO19 (Phone Call Delivery), DUO65 (Phone Call Delivery), DUO12 (Phone Call Delivery), DUO3 (Phone Call Delivery), DUO59 (Phone Call Delivery), DUO10 (Phone Call Delivery), DUO52 (Phone Call Delivery), DUO30 (Phone Call Delivery), DUO17 (Phone Call Delivery), DUO24 (Phone Call Delivery), DUO47 (Phone Call Delivery), DUO22 (Phone Call Delivery), DUO63 (Phone Call Delivery), DUO27 (Phone Call Delivery), DUO23 (Phone Call Delivery), DUO55 (Phone Call Delivery), DUO48 (Phone Call Delivery), DUO4 (Phone Call Delivery), DUO37 (Phone Call Delivery), DUO11 (Phone Call Delivery), DUO20 (Phone Call Delivery), DUO44 (Phone Call Delivery), DUO31 (Phone Call Delivery), DUO38 (Phone Call Delivery), DUO32 (Phone Call Delivery), DUO40 (Phone Call Delivery), DUO7 (Phone Call Delivery), DUO41 (Phone Call Delivery), DUO39 (Phone Call Delivery), DUO21 (Phone Call Delivery), DUO64 (Phone Call Delivery), DUO50 (Phone Call Delivery), DUO5 (Phone Call Delivery), DUO33 (Phone Call Delivery), DUO16 (Phone Call Delivery), DUO42 (Phone Call Delivery), DUO43 (Phone Call Delivery), DUO58 (Phone Call Delivery), DUO6 (Phone Call Delivery), DUO45 (Phone Call Delivery), DUO29 (Phone Call Delivery), DUO46 (Phone Call Delivery), DUO36 (Phone Call Delivery), and DUO35 (Phone Call Delivery).