We have deployed a fix for the issue that preventing administrators from accessing Activity Logs in the Admin Panel. We are continually monitoring the results of the fix at this time.
Posted Jun 20, 2025 - 22:29 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 20, 2025 - 06:20 EDT
Identified
We have identified the issue preventing administrators from accessing activity logs in the admin panel. We are continuing to work towards deploying a fix at this time.
Posted Jun 19, 2025 - 14:16 EDT
Monitoring
We are seeing increased success of accessing the Activity Logs for the impacted deployments DUO55 and DUO68.
We will continue to monitor the success rate at this time.
Posted Jun 19, 2025 - 10:39 EDT
Identified
We have identified the issue preventing administrators from accessing activity logs in the admin panel. We are working to deploy a fix at this time.
Posted Jun 19, 2025 - 03:46 EDT
Investigating
We are investigating an issue affecting administrator access to activity logs in the DUO68/DUO55 Deployments.
Posted Jun 19, 2025 - 03:27 EDT
This incident affects: DUO55 (Admin Panel), DUO68 (Admin Panel), and DUO74 (Admin Panel).