Duo Push failures
Incident Report for Duo
Resolved
After reviewing the issues reported, this issue is being caused by ISP disruptions. For further assistance on this, please consider contacting your ISP. We will continue to monitor.
Posted Jun 18, 2024 - 07:31 EDT
Monitoring
After investigating, we have determined that our services are fully operational, and some customers might be impacted by various outages from their respective Internet Service Providers. Please check with your ISP for further troubleshooting.
Posted Jun 18, 2024 - 06:52 EDT
Investigating
We are currently investigating an issue causing Duo Push failures. Please check back here or subscribe to updates for any changes.
Posted Jun 18, 2024 - 06:10 EDT