Phone Support Handling Issue
Incident Report for Duo
Resolved
We have confirmed that the issue has been resolved and support calling is operational.
Posted Mar 23, 2022 - 16:03 EDT
Identified
Support phone call connectivity has improved and we are currently monitoring for stability.
Posted Mar 23, 2022 - 13:29 EDT
Investigating
Duo Support is currently investigating an issue disrupting call connectivity between customers and our Support Engineers. We are working with the appropriate teams to address the core issue. If you need to contact Duo Support, we recommend contacting us via email or the Support Ticket Portal for less urgent matters.
Posted Mar 23, 2022 - 12:54 EDT
This incident affected: Duo Support (Phone Support).