Error on billing page.
Incident Report for Duo Security
Resolved
The error occurring on Billing page in the Duo Admin Panel that caused it to display the message "Error retrieving billing information." has been resolved and the Billing page is fully operational.
Posted about 1 year ago. Jun 03, 2016 - 11:38 EDT
Monitoring
We have deployed a fix for the error occurring on Billing page in the Duo Admin Panel that caused it to display the message "Error retrieving billing information." This issue did not affect billing status, licensing, or any Duo-protected applications. All applications and authentications remain fully functional. We will continue to monitor the issue.
Posted about 1 year ago. Jun 03, 2016 - 10:13 EDT
Identified
We are currently investigating a problem with the Billing page in the Duo Admin Panel. This is causing the page to display the message "Error retrieving billing information." This issue does not affect your billing status, licensing, or any Duo-protected applications. All applications and authentications are fully functional at this time.
Posted about 1 year ago. Jun 03, 2016 - 08:21 EDT
This incident affected: DUO6 (Core Authentication Service), DUO25 (Admin Panel), DUO29 (Admin Panel), DUO19 (Admin Panel), DUO16 (Admin Panel), DUO2 (Admin Panel), DUO17 (Admin Panel), DUO41 (Admin Panel), DUO38 (Admin Panel), DUO37 (Admin Panel), DUO34 (Admin Panel), DUO36 (Admin Panel), DUO39 (Admin Panel), DUO32 (Admin Panel), DUO40 (Admin Panel), DUO28 (Admin Panel), DUO23 (Admin Panel), DUO22 (Admin Panel), DUO26 (Admin Panel), DUO24 (Admin Panel), DUO20 (Admin Panel), DUO15 (Admin Panel), DUO13 (Admin Panel), DUO11 (Admin Panel), DUO21 (Admin Panel), DUO18 (Admin Panel), DUO12 (Admin Panel), DUO30 (Admin Panel), DUO8 (Admin Panel), DUO7 (Admin Panel), DUO3 (Admin Panel), DUO1 (Admin Panel), DUO47 (Admin Panel), DUO33 (Admin Panel), DUO31 (Admin Panel), DUO10 (Admin Panel), DUO14 (Admin Panel), DUO27 (Admin Panel), DUO4 (Admin Panel), and DUO35 (Admin Panel).