SMS Delivery issue

Incident Report for Duo

Resolved

The SMS delivery issue has been resolved, and all services are fully functional.
Posted Sep 10, 2024 - 04:31 EDT

Investigating

We are investigating an issue with SMS Delivery. Please check back for further updates.
Posted Sep 10, 2024 - 04:00 EDT