Internet Outage
Incident Report for Duo
Resolved
We have received confirmation from our provider that all residual issues with Trusted Endpoint certificate generation and management system creation are now also resolved. All Duo services are fully functional.
Posted Jul 19, 2024 - 20:09 EDT
Update
We have reviewed the current situation and can confirm that Duo services remain fully operational and continuing to monitor for any further issue. We are unable to provide any status related updates for the external issues.
Posted Jul 19, 2024 - 08:03 EDT
Update
We are continuing to monitor for any further issues and can confirm that Duo services remain fully operational. We are unable to provide any status related updates for the external issues.
Posted Jul 19, 2024 - 05:50 EDT
Update
We are currently monitoring multiple customer reports indicating connectivity issues with Duo services and believe this is related to current external issues. We confirm that Duo's services remain fully operational, provided that a stable network route is maintained, and we are unable to issue or renew certs for Trusted Endpoints.
We also recommend reaching out to your ISP for assistance and checking their status page for the latest updates on this matter.
Posted Jul 19, 2024 - 04:29 EDT
Update
We are currently monitoring multiple customer reports indicating connectivity issues with Duo services and believe this is related to current external issues. We confirm that Duo's services remain fully operational, provided that a stable network route is maintained. We also recommend reaching out to your ISP for assistance and checking their status page for the latest updates on this matter.
Posted Jul 19, 2024 - 04:02 EDT
Update
We are continuing to monitor for any further issues.
Posted Jul 19, 2024 - 03:09 EDT
Update
We are continuing to monitor for any further issues.
Posted Jul 19, 2024 - 03:02 EDT
Monitoring
We are continuing to monitor for any further issues.
Posted Jul 19, 2024 - 02:58 EDT
Investigating
We are currently conducting a thorough investigation into multiple customer reports indicating connectivity issues with Duo services, specifically from users with certain Internet Service Providers (ISPs). Preliminary findings suggest that these issues may originate from a peering provider utilized by several of these ISPs. Our team is actively working to gather more information and will issue further updates as soon as additional details become available. We confirm that Duo's services remain fully operational, provided that a stable network route is maintained. We also recommend reaching out to your ISP for assistance and checking their status page for the latest updates on this matter.
Posted Jul 19, 2024 - 02:54 EDT