UAE Telephony SMS issue

Incident Report for Duo

Monitoring

We have mitigated the SMS delivery issue affecting the UAE region. We are actively monitoring the situation and will provide a final update once the issue is fully resolved.
Posted Jun 23, 2026 - 04:29 EDT

Identified

We have identified the issue related to SMS for UAE region and are working to resolve it.
Users have the option to use alternative auth methods, like Duo Push or VoIP.

Please check back here or subscribe to updates for any changes.
Posted Jun 22, 2026 - 23:58 EDT
This incident affects: DUO81 (SMS Message Delivery).