Duo Support Phone System Issue
Incident Report for Duo
Resolved
All issues with our phone call support system have been resolved and the system is functioning as expected. Thank you for your patience.
Posted Jul 27, 2021 - 16:15 EDT
Investigating
Duo Support is currently investigating an issue disrupting call connectivity between customers and our Support Engineers. We are working with the appropriate teams to address the core issue. If you need to contact Duo Support, we recommend contacting us via chat for more critical needs or email for less urgent matters.
Posted Jul 27, 2021 - 11:45 EDT
This incident affected: Duo Support (Phone Support).