DUO39: Authentication Prompt Issues
Incident Report for Duo
Postmortem

From 13:00 to 13:40 UTC on July 18, 2017, the DUO39 deployment experienced increased authentication latency that caused authentication failure for some customer applications protected by the Duo service.

As part of our rolling release process, Duo consistently makes new features and other general service improvements available to customers. Duo’s engineering team has implemented processes allowing these types of changes to be made in a gradual and automated fashion, and these processes are exercised regularly as Duo releases code on a biweekly basis.

On July 13th, the latest software release of the Duo platform was deployed to DUO39 without issue. This release contained a number of performance improvements and laid the groundwork for an upcoming feature enhancement. A defect in the code supporting this upcoming feature enhancement resulted in database performance issues under a specific, unique workload. This defect went undetected until this specific workload was exercised on the morning of July 18th.

Duo’s monitoring systems detected and alerted engineering team members to an elevated but not yet service impacting increase in database latency at 12:40 UTC on July 18th. While the issue was being investigated, database latency increased to service impacting levels beginning at 13:00 UTC. Once the team was able to determine root cause, a software patch was developed and deployed to the DUO39 deployment. Service stabilized and all authentication requests began being processed as expected at that time.

Duo’s engineering team has integrated this patch into the core version of our software to prevent future occurrences of this regression. The team will also evaluate the load testing methodologies used to test this enhancement prior to release to identify opportunities to better detect this sort of issue going forward.

Posted Jul 18, 2017 - 15:55 EDT

Resolved
Our Engineering Team has resolved the underlying cause of increased authentication latency against DUO39. Latency continues to hold at expected levels and no further issues are anticipated. We will provide a detailed analysis of the incident after further investigation.
Posted Jul 18, 2017 - 11:22 EDT
Monitoring
Our Engineering Team has deployed a fix to solve latency issues on DUO39. We will continue to monitor the situation to ensure the issue is fully resolved.
Posted Jul 18, 2017 - 10:30 EDT
Identified
Our Engineering Team has identified the issue causing latency on DUO39 and is actively deploying a fix. We will continue monitoring the issue and provide further updates.
Posted Jul 18, 2017 - 09:57 EDT
Investigating
Our Engineering Team is investigating authentication latency issues on the DUO39 instance. We will provide updates as soon as possible.
Posted Jul 18, 2017 - 09:37 EDT
This incident affected: DUO39 (Core Authentication Service).