New Signups Unavailable

Incident Report for Duo

Resolved

This incident has been resolved.

New Duo account registrations are now functioning normally.

Thank you for your patience. If you continue to experience issues, please contact Duo Support.
Posted Aug 10, 2026 - 18:46 EDT

Identified

We have identified the issue affecting new account registrations. Our team is working on a fix and expects to release it soon.

We apologize for any inconvenience and appreciate your continued patience.
Posted Aug 10, 2026 - 17:04 EDT

Investigating

We are investigating an issue affecting the signup service. New account registrations are temporarily unavailable.

Our team is actively investigating and working to restore normal service. We apologize for any inconvenience and appreciate your patience.
Posted Aug 10, 2026 - 16:34 EDT