DUO62 - Admin Panel login issues
Incident Report for Duo
Resolved
This incident is now resolved. A root cause analysis (RCA) will be posted as soon as it is available.
Posted Nov 05, 2021 - 19:02 EDT
Monitoring
We are currently investigating an issue that transpired between 17:27 EDT and 17:51 EDT.

This event affected logging into admin.duosecurity.com or from the button on the top right of duo.com. Some customers may have seen an error when trying to log in.

Navigating directly to your specific URL for your Admin Panel (admin-.duosecurity.com) would still have worked during this incident, as a workaround.

Affected Deployment
DUO62

We believe this issue to be resolved, and are monitoring to ensure no recurrences are observed.
Posted Nov 05, 2021 - 18:06 EDT
This incident affected: DUO62 (Admin Panel).