Error message "Unknown Error" appearing when accessing Applications in the Duo Admin Panel
Incident Report for Duo
Postmortem

After further review, it appears that some customers did experience a very brief impact to their user authentications during the time period when this outage occurred.

Duo utilizes many caching layers to ensure expedient access to critical data during the authentication process. Software version data is one such example of this type of data as it is read frequently, but changes infrequently. During the incident some deployments refreshed their cache for software version data and loaded erroneous data into the cache. This resulted in errors being displayed during authentication. 1,876 authentications were affected across all deployments during this outage.

We have updated our error detection to ensure that we are aware of and include any information about these types of issues moving forward. We are also making updates to our platform to ensure that this type of issue will not re-occur.

Posted Dec 02, 2019 - 14:05 EST

Resolved
From approximately 3:36 PM to 3:56 PM EST, some customers encountered an error message displaying “Unknown Error” when attempting to edit an application’s settings in the Duo Admin Panel.

Duo routinely programmatically identifies new versions of operating systems and browsers as part of the Duo platform’s ability to enforce policy based on browser and OS version. Today a pre-release version of an operating system was identified and mistakenly set as the most current publicly available version of that operating system. Because this pre-release version has yet to be given an official version number by the vendor, an issue occurred when Duo’s policy engine attempted to determine the version number for this OS.

Duo’s Engineering team was alerted to this issue at 3:36 PM and immediately diagnosed and corrected the affected data within the platform. Updates to the platform are already underway to ensure that this issue does not happen again.
Posted Nov 12, 2019 - 16:00 EST