All Deployments: Activation SMS Delivery Issues for some Canadian phone numbers
Incident Report for Duo
Resolved
Incident Report - 2019/10/01


Summary

SMS messages containing activation links for Duo Mobile were not reaching users of three cellular carriers in Canada from Mid-September to October 1, 2019. This issue affected less than 900 activation messages sent after Duo developed remediations for SMS delivery in Canada following an issue in mid-September. No authentications were affected.

Details

Duo’s Support Team received notification on October 1, 2019 of issues affecting the delivery of SMS messages to Canadian phone numbers. After initial investigation, the Support team alerted Duo’s Engineering team at 8:47 p.m. EDT with confirmation that some end users were not receiving SMS messages. It was determined at At 9:24 p.m. EDT that the impact of this issue was limited to SMS messages to activate Duo Mobile for users with Canadian area codes.

Following investigation, the Engineering Team discovered that the number being used to send activation messages was being blocked by Canadian carriers. The team validated in our staging environment that using our special purpose pool of numbers for delivering SMS to Canadian phone numbers remediated the issue. Duo Engineering then began deploying the changes across production at 10:12 p.m. EDT. By 10:39 p.m. EDT, we received reports from affected customers that SMS messages were being delivered. The deployment to all customers was complete by 1:33 a.m. EDT. Following the solution’s deployment, we monitored the delivery of messages and confirmed the service was restored.

The special purpose pool of phone numbers for sending SMS messages to Canadian phone numbers will be used for both authentication and activation messages going forward.
Posted Oct 02, 2019 - 11:57 EDT
Monitoring
Our Engineering team has successfully resolved the issues with Duo Mobile Activation SMS delivery to Canadian phone numbers, and we have confirmed that affected customers are seeing successful delivery.

We will continue to monitor the issue to ensure it is completely resolved.
Posted Oct 02, 2019 - 03:43 EDT
Identified
This issue has been identified and only affects Duo Mobile Activation SMS messages; authentications are not impacted.

Our Engineering team is currently remediating the issue.
Posted Oct 01, 2019 - 21:36 EDT
Investigating
We are currently investigating an issue causing SMS delivery issues for some Canadian phone numbers and are working to correct the issue as soon as possible.

Please check back here or subscribe to updates for any changes.
Posted Oct 01, 2019 - 21:11 EDT
This incident affected: DUO15 (SMS Message Delivery), DUO5 (SMS Message Delivery), DUO39 (SMS Message Delivery), DUO48 (SMS Message Delivery), DUO14 (SMS Message Delivery), DUO32 (SMS Message Delivery), DUO36 (SMS Message Delivery), DUO29 (SMS Message Delivery), DUO38 (SMS Message Delivery), DUO41 (SMS Message Delivery), DUO65 (SMS Message Delivery), DUO45 (SMS Message Delivery), DUO24 (SMS Message Delivery), DUO2 (SMS Message Delivery), DUO3 (SMS Message Delivery), DUO16 (SMS Message Delivery), DUO34 (SMS Message Delivery), DUO60 (SMS Message Delivery), DUO30 (SMS Message Delivery), DUO12 (SMS Message Delivery), DUO19 (SMS Message Delivery), DUO44 (SMS Message Delivery), DUO4 (SMS Message Delivery), DUO46 (SMS Message Delivery), DUO21 (SMS Message Delivery), DUO50 (SMS Message Delivery), DUO51 (SMS Message Delivery), DUO28 (SMS Message Delivery), DUO27 (SMS Message Delivery), DUO11 (SMS Message Delivery), DUO33 (SMS Message Delivery), DUO54 (SMS Message Delivery), DUO49 (SMS Message Delivery), DUO64 (SMS Message Delivery), DUO10 (SMS Message Delivery), DUO47 (SMS Message Delivery), DUO17 (SMS Message Delivery), DUO8 (SMS Message Delivery), DUO18 (SMS Message Delivery), DUO9 (SMS Message Delivery), DUO52 (SMS Message Delivery), DUO42 (SMS Message Delivery), DUO1 (SMS Message Delivery), DUO22 (SMS Message Delivery), DUO13 (SMS Message Delivery), DUO26 (SMS Message Delivery), DUO55 (SMS Message Delivery), DUO37 (SMS Message Delivery), DUO23 (SMS Message Delivery), DUO20 (SMS Message Delivery), DUO59 (SMS Message Delivery), DUO31 (SMS Message Delivery), DUO43 (SMS Message Delivery), DUO58 (SMS Message Delivery), DUO56 (SMS Message Delivery), DUO57 (SMS Message Delivery), DUO25 (SMS Message Delivery), DUO40 (SMS Message Delivery), DUO63 (SMS Message Delivery), DUO61 (SMS Message Delivery), DUO7 (SMS Message Delivery), DUO6 (SMS Message Delivery), DUO62 (SMS Message Delivery), DUO53 (SMS Message Delivery), and DUO35 (SMS Message Delivery).