All Deployments: Duo Enrollment URL Session Expired Errors

Incident Report for Duo

Postmortem

Enrollment Timeout Outage

Incident Report – 02/04/2026

Summary

A recent software update Duo made related to certificate security improvements inadvertently changed the order of operations for user sessions in our legacy enrollment experience. This resulted in user sessions not being properly initialized, prompting the system to mistakenly identify these sessions as expired. Affected users were unable to complete enrollment and saw the message: “Your session has expired. Please try again.” The issue only affected enrollment flows using the legacy Traditional Prompt. Customers were able to successfully enroll by switching to the Universal Prompt enrollment experience as a workaround.

Duo identified and corrected the issue by ensuring sessions are fully initialized before they are used. The fix was deployed on 2026-02-04, and enrollment is now functioning normally.

Duo has implemented additional safeguards to prevent similar session handling issues in future updates.

Timeline of Events

Date/Time (in EST)

02/04/2026 03:57AM  - Duo receives reports that customers are unable to complete enrollments

02/04/2026 09:00 AM - Authentication team starts investigating

02/04/2026 10:42 AM - Authentication team identifies root cause

02/04/2026 3:40 PM - The fix begins rolling out to customers

02/04/2026 7:26 PM - The fix finishes rolling out to customers

02/04/2026 7:26 PM - Duo confirms that enrollments are working as intended

Posted Feb 10, 2026 - 16:20 EST

Resolved

The issue causing enrollment failures that display the error message "Your session has expired. Please try again." has been resolved.
Posted Feb 04, 2026 - 20:11 EST

Monitoring

We have implemented a fix for the enrollment failures that caused the error message "Your session has expired. Please try again." and are monitoring the results closely.
Posted Feb 04, 2026 - 19:56 EST

Identified

We have Identified the cause of enrollment failures that display the error message "Your session has expired. Please try again." and are working to correct the issue as soon as possible.

As a workaround:
-If using enrollment email links, update the enrollment experience settings (https://duo.com/docs/administration-settings#enrollment) to show New Universal Prompt.
-If enrolling using in-line self enrollment with an existing application (https://duo.com/docs/enrolling-users#inline-self-enrollment), update that application to use the Universal Prompt (https://duo.com/docs/universal-prompt-update-guide).
-You can also enroll users manually from the Duo Admin Panel (https://duo.com/docs/administration-devices#adding-a-2fa-device-to-a-user) or issue an enrollment code for self-enrollment (https://duo.com/docs/enrolling-users#generate-enrollment-codes-for-existing-users).

Please check back here or subscribe to updates for any changes.
Posted Feb 04, 2026 - 13:55 EST
This incident affected: DUO6 (Admin Panel), DUO1 (Admin Panel), DUO2 (Admin Panel), DUO3 (Admin Panel), DUO4 (Admin Panel), DUO5 (Admin Panel), DUO7 (Admin Panel), DUO8 (Admin Panel), DUO47 (Admin Panel), DUO10 (Admin Panel), DUO11 (Admin Panel), DUO12 (Admin Panel), DUO13 (Admin Panel), DUO14 (Admin Panel), DUO15 (Admin Panel), DUO16 (Admin Panel), DUO17 (Admin Panel), DUO18 (Admin Panel), DUO19 (Admin Panel), DUO20 (Admin Panel), DUO21 (Admin Panel), DUO22 (Admin Panel), DUO23 (Admin Panel), DUO24 (Admin Panel), DUO25 (Admin Panel), DUO26 (Admin Panel), DUO27 (Admin Panel), DUO28 (Admin Panel), DUO29 (Admin Panel), DUO30 (Admin Panel), DUO31 (Admin Panel), DUO32 (Admin Panel), DUO33 (Admin Panel), DUO34 (Admin Panel), DUO36 (Admin Panel), DUO37 (Admin Panel), DUO38 (Admin Panel), DUO39 (Admin Panel), DUO40 (Admin Panel), DUO41 (Admin Panel), DUO42 (Admin Panel), DUO44 (Admin Panel), DUO45 (Admin Panel), DUO46 (Admin Panel), DUO48 (Admin Panel), DUO9 (Admin Panel), DUO49 (Admin Panel), DUO50 (Admin Panel), DUO51 (Admin Panel), DUO52 (Admin Panel), DUO53 (Admin Panel), DUO54 (Admin Panel), DUO55 (Admin Panel), DUO56 (Admin Panel), DUO57 (Admin Panel), DUO58 (Admin Panel), DUO59 (Admin Panel), DUO60 (Admin Panel), DUO62 (Admin Panel), DUO63 (Admin Panel), DUO65 (Admin Panel), DUO66 (Admin Panel), DUO67 (Admin Panel), DUO68 (Admin Panel), DUO69 (Admin Panel), DUO70 (Admin Panel), DUO71 (Admin Panel), DUO72 (Admin Panel), DUO73 (Admin Panel), DUO74 (Admin Panel), DUO75 (Admin Panel), DUO76 (Admin Panel), DUO77 (Admin Panel), DUO78 (Admin Panel), DUO79 (Admin Panel), DUO80 (Admin Panel), DUO81 (Admin Panel), and DUO35 (Admin Panel).