"40102: Invalid integration key in request credentials" errors with Juniper UAC applications
Incident Report for Duo Security
Resolved
Juniper UAC integrations now work correctly as described in https://duo.com/docs/juniper-uac. The work-around is no longer required, but will continue to work in addition to the instructions in our documentation.
Posted 6 months ago. Jun 19, 2018 - 20:41 EDT
Identified
The underlying issue has been identified and a fix is being developed and tested. All other authentications and application types remain unaffected.
Posted 6 months ago. Jun 18, 2018 - 22:08 EDT
Investigating
Duo's engineering team is currently investigating some increased reports of the error "40102: Invalid integration key in request credentials" errors with applications of the type "Juniper UAC".

To work around this issue:
1. Create an application with the type "Juniper SSLVPN" in the Duo Admin Panel
2. Copy and paste the ikey and skey values from the Duo Admin Panel into your authproxy.cfg in place of your Juniper UAC application's existing ikey and skey
3. Restart the authentication proxy service

We'll send out another update once a permanent fix for this issue has been fully tested and released.
Posted 6 months ago. Jun 18, 2018 - 21:28 EDT
This incident affected: DUO56 (Core Authentication Service), DUO55 (Core Authentication Service), DUO58 (Core Authentication Service), DUO51 (Core Authentication Service), DUO42 (Core Authentication Service), DUO54 (Core Authentication Service), DUO49 (Core Authentication Service), DUO9 (Core Authentication Service), DUO50 (Core Authentication Service), DUO52 (Core Authentication Service), DUO32 (Core Authentication Service), DUO1 (Core Authentication Service), DUO47 (Core Authentication Service), DUO45 (Core Authentication Service), DUO46 (Core Authentication Service), DUO38 (Core Authentication Service), DUO53 (Core Authentication Service), DUO48 (Core Authentication Service), DUO37 (Core Authentication Service), DUO36 (Core Authentication Service), DUO44 (Core Authentication Service), DUO43 (Core Authentication Service), DUO39 (Core Authentication Service), DUO40 (Core Authentication Service), DUO41 (Core Authentication Service), DUO27 (Core Authentication Service), DUO26 (Core Authentication Service), DUO29 (Core Authentication Service), DUO23 (Core Authentication Service), DUO22 (Core Authentication Service), DUO25 (Core Authentication Service), DUO21 (Core Authentication Service), DUO24 (Core Authentication Service), DUO16 (Core Authentication Service), DUO11 (Core Authentication Service), DUO14 (Core Authentication Service), DUO8 (Core Authentication Service), DUO10 (Core Authentication Service), DUO7 (Core Authentication Service), DUO28 (Core Authentication Service), DUO17 (Core Authentication Service), DUO20 (Core Authentication Service), DUO33 (Core Authentication Service), DUO31 (Core Authentication Service), DUO18 (Core Authentication Service), DUO15 (Core Authentication Service), DUO34 (Core Authentication Service), DUO3 (Core Authentication Service), DUO19 (Core Authentication Service), DUO13 (Core Authentication Service), DUO12 (Core Authentication Service), DUO5 (Core Authentication Service), DUO30 (Core Authentication Service), DUO2 (Core Authentication Service), DUO4 (Core Authentication Service), DUO59 (Core Authentication Service), DUO57 (Core Authentication Service), DUO6 (Core Authentication Service), and DUO35 (Core Authentication Service).