SMS Delivery Issues
Incident Report for Duo Security
Resolved
Our operations team appears to have resolved this issue with our primary telephony provider and we have received confirmation that messages are being expediently delivered once again.
Posted about 1 year ago. Jan 14, 2016 - 18:15 EST
Investigating
We are investigating reports that outgoing SMS messages are delayed. We have contacted our telephony provider regarding this issue and are in the process of failing over to a backup provider.
Posted about 1 year ago. Jan 14, 2016 - 17:34 EST
This incident affected: DUO1 (SMS Message Delivery).