All Deployments: Self-Service Billing Issues
Incident Report for Duo
Resolved
The Self-Service billing issue has been resolved. As of 3:00 PM UTC, everything is operating normally.
Posted Aug 08, 2022 - 11:03 EDT
Monitoring
We are currently monitoring an issue causing an outage with our Self-Service billing functionality.
Posted Aug 08, 2022 - 10:04 EDT
This incident affected: DUO6 (Admin Panel), DUO27 (Admin Panel), DUO51 (Admin Panel), DUO23 (Admin Panel), DUO28 (Admin Panel), DUO26 (Admin Panel), DUO44 (Admin Panel), DUO41 (Admin Panel), DUO48 (Admin Panel), DUO43 (Admin Panel), DUO46 (Admin Panel), DUO66 (Admin Panel), DUO60 (Admin Panel), DUO14 (Admin Panel), DUO25 (Admin Panel), DUO30 (Admin Panel), DUO59 (Admin Panel), DUO36 (Admin Panel), DUO11 (Admin Panel), DUO34 (Admin Panel), DUO21 (Admin Panel), DUO67 (Admin Panel), DUO20 (Admin Panel), DUO2 (Admin Panel), DUO12 (Admin Panel), DUO4 (Admin Panel), DUO68 (Admin Panel), DUO53 (Admin Panel), DUO37 (Admin Panel), DUO15 (Admin Panel), DUO32 (Admin Panel), DUO7 (Admin Panel), DUO1 (Admin Panel), DUO63 (Admin Panel), DUO5 (Admin Panel), DUO31 (Admin Panel), DUO16 (Admin Panel), DUO10 (Admin Panel), DUO19 (Admin Panel), DUO24 (Admin Panel), DUO18 (Admin Panel), DUO54 (Admin Panel), DUO38 (Admin Panel), DUO33 (Admin Panel), DUO22 (Admin Panel), DUO39 (Admin Panel), DUO56 (Admin Panel), DUO17 (Admin Panel), DUO9 (Admin Panel), DUO58 (Admin Panel), DUO50 (Admin Panel), DUO64 (Admin Panel), DUO52 (Admin Panel), DUO55 (Admin Panel), DUO65 (Admin Panel), DUO42 (Admin Panel), DUO49 (Admin Panel), DUO62 (Admin Panel), DUO40 (Admin Panel), DUO61 (Admin Panel), DUO57 (Admin Panel), DUO45 (Admin Panel), DUO70 (Admin Panel), DUO69 (Admin Panel), DUO3 (Admin Panel), DUO47 (Admin Panel), DUO13 (Admin Panel), DUO8 (Admin Panel), DUO29 (Admin Panel), and DUO35 (Admin Panel).