[Multiple Deployments] Admin Panel Login Issues
Incident Report for Duo
Resolved
Duo Admin Panel logins continue to be successful and all services are fully operational. This incident is resolved.
Posted Sep 30, 2024 - 14:55 EDT
Monitoring
After continuous testing on our side, we are confident that the issues were short-lived and transient in nature. We are continuing to monitor for any potential uptick in failure rates for Admin Panel logins and will provide updates if/when available.
Posted Sep 30, 2024 - 14:17 EDT
Investigating
We are currently investigating an issue causing an error when logging into the Duo Admin Panel.

Please check back here or subscribe to updates for any changes.
Posted Sep 30, 2024 - 11:10 EDT
This incident affected: DUO47 (Admin Panel), DUO74 (Admin Panel), and DUO75 (Admin Panel).