Admin functions impacted when accessing Users and AD Sync on certain deployments

Incident Report for Duo

Resolved

The issue affecting User Management and SSO logins on Duo3, Duo47, and Duo57 has been fully resolved, and all services have been restored to normal functionality.


We will publish a RCA as soon as it is available. You can check back here for the latest information or subscribe for updates.
Posted Aug 26, 2025 - 07:43 EDT

Monitoring

Following the implementation of the fix, we are seeing signs of recovery. We will continue to actively monitor the results to ensure the issue is fully resolved.

Please refer to the status page for further updates.
Posted Aug 26, 2025 - 05:29 EDT

Identified

A fix has been deployed for the issue affecting User Management and SSO logins on Duo3, Duo47, and Duo57. We are monitoring performance and stability. Please refer to the status page for further updates.
Posted Aug 26, 2025 - 05:06 EDT

Update

We are continuing to investigate this issue.
Posted Aug 26, 2025 - 04:09 EDT

Investigating

We are currently investigating an issue impacting user management and Active Directory sync on selected deployments. Please refer to the status page for further updates.
Posted Aug 26, 2025 - 04:08 EDT
This incident affected: DUO3 (Admin Panel, SSO), DUO47 (Admin Panel, SSO), and DUO57 (Admin Panel, SSO).