Chat Support Handling Issue
Incident Report for Duo
Resolved
All issues with our our chat support system, Duo Support Portal and help.duo.com have been resolved and the system is functioning as expected. Thank you for your patience.
Posted May 12, 2021 - 00:07 EDT
Monitoring
All issues with our chat support system, Duo Support Portal and help.duo.com have been resolved and the system is functioning as expected. We are continuing to closely monitor to ensure stability.
Posted May 11, 2021 - 21:24 EDT
Investigating
Duo Support is currently investigating an issue disrupting chat support services between customers and our Support Engineers. This is also causing issues with customers' ability to view and submit support tickets via the Duo Support Portal and viewing knowledge base articles at help.duo.com.
We are working with the appropriate teams to address the core issue.
If you need to contact Duo Support, we recommend contacting us via phone for more critical needs or email for less urgent matters.
Posted May 11, 2021 - 20:26 EDT
This incident affected: Duo Support (Chat Support).