Multiple Deployments: Intermittent Duo Authentication and Admin Panel access failures.
Incident Report for Duo
Resolved
The issue causing Duo authentication failures and Admin Panel access issues is fully resolved and all services are now fully functional.
Posted Apr 21, 2024 - 02:55 EDT
Monitoring
We are now seeing that Duo Authentications and Admin Panel access is successful and trending at normal rates.

We will continue to monitor the issue and will post any updates when the incident is considered fully resolved.
Posted Apr 21, 2024 - 02:15 EDT
Investigating
We are currently investigating an issue causing intermittent Duo authentication failures and Admin Panel access issues on some of our deployments and are working to correct the issue as soon as possible.

Deployments Affected:
DUO9
DUO14
DUO15
DUO19
DUO21
DUO24
DUO33
DUO40
DUO41
DUO45
DUO55
DUO62
DUO63

Please check back here or subscribe to updates for any changes.
Posted Apr 21, 2024 - 01:50 EDT
This incident affected: DUO14 (Core Authentication Service, Admin Panel), DUO15 (Core Authentication Service, Admin Panel), DUO19 (Core Authentication Service, Admin Panel), DUO21 (Core Authentication Service, Admin Panel), DUO24 (Core Authentication Service, Admin Panel), DUO33 (Core Authentication Service, Admin Panel), DUO40 (Core Authentication Service, Admin Panel), DUO41 (Core Authentication Service, Admin Panel), DUO45 (Core Authentication Service, Admin Panel), DUO9 (Core Authentication Service, Admin Panel), DUO55 (Core Authentication Service, Admin Panel), DUO62 (Core Authentication Service, Admin Panel), and DUO63 (Core Authentication Service, Admin Panel).