Signup Issues
Incident Report for Duo
Resolved
New customer signups are now completing successfully. A vendor Duo utilizes experienced a degradation that lead to difficulty associating customers with our services.
Posted Jan 24, 2020 - 19:07 EST
Investigating
We are currently investigating reports of new customer signup issues. No current customers are affected.
Posted Jan 24, 2020 - 18:21 EST