Elevated Authentication Latency in DUO6

Incident Report for Duo

Resolved

The issue causing elevated authentication latency has been fully resolved. Authentication performance has returned to normal levels, and customers should no longer experience delays during login attempts.
Posted Apr 28, 2026 - 11:26 EDT

Monitoring

We have applied mitigation steps and are seeing improved authentication performance for customers in the deployment. Authentication latency has decreased, and the service is recovering. Our team is continuing to monitor the environment closely to ensure stability while we investigate the underlying cause.
Posted Apr 28, 2026 - 10:56 EDT

Investigating

We are investigating elevated authentication latency affecting customers . Authentication requests are continuing to succeed at this time, but customers may experience slower-than-normal response times and degraded performance during login attempts. Our team is actively working to identify the cause and restore normal performance as quickly as possible.
Posted Apr 28, 2026 - 10:22 EDT
This incident affected: DUO6 (Core Authentication Service).