Desktop Authenticator Enrollment Degradation

Incident Report for Duo

Resolved

The issue has been resolved. Services have returned to normal operation, and customers should no longer experience delays or failures.
We apologize for any inconvenience caused and thank you for your patience.
Posted Apr 30, 2026 - 14:07 EDT

Monitoring

Mitigation actions have been implemented. The service has stabilized and recovery is underway. We will continue to monitor to ensure full resolution.
Posted Apr 30, 2026 - 13:57 EDT

Identified

We are currently addressing an issue impacting desktop authenticator enrollments .A subset of customers may experience intermittent delays or failures during desktop authenticator enrollment. Mitigation actions are in progress and are helping to reduce impact. Core authentication, SSO, and delivery services  remain fully operational.
Posted Apr 30, 2026 - 13:54 EDT
This incident affected: DUO17 (Admin Panel), DUO22 (Admin Panel), DUO39 (Admin Panel), DUO40 (Admin Panel), DUO42 (Admin Panel), DUO9 (Admin Panel), DUO49 (Admin Panel), DUO50 (Admin Panel), DUO52 (Admin Panel), DUO55 (Admin Panel), DUO56 (Admin Panel), DUO58 (Admin Panel), DUO62 (Admin Panel), DUO63 (Admin Panel), DUO65 (Admin Panel), DUO72 (Admin Panel), DUO73 (Admin Panel), DUO74 (Admin Panel), DUO75 (Admin Panel), DUO76 (Admin Panel), DUO77 (Admin Panel), and DUO78 (Admin Panel).