All Deployments: SMS Delivery Issues
Incident Report for Duo
Resolved
The issue regarding the delivery of SMS messages is fully resolved and all services are now fully functional.
Posted May 29, 2021 - 23:30 EDT
Monitoring
Our telephony service provider has confirmed that the issue has been resolved and we have observed normal SMS delivery for over 16 hours.

We will continue to monitor SMS delivery and will update this page in case of new information or developments.
Please continue to visit this status page or subscribe here for further updates.
Posted May 29, 2021 - 06:20 EDT
Update
Our telephony service provider has confirmed that the issue has been resolved and we have observed normal SMS delivery for over 16 hours.

We will continue to monitor SMS delivery and will update this page in case of new information or developments.
Please continue to visit this status page or subscribe here for further updates.
Posted May 29, 2021 - 06:16 EDT
Identified
We have identified the cause of the SMS delivery issues and are working closely with our telephony service provider to get them resolved. We have observed normal SMS delivery activity over the past three hours and we will continue to monitor. We will update this page with new status when we have more information to share.

Please continue to visit this status page or subscribe here for further updates.
Posted May 28, 2021 - 16:16 EDT
Investigating
We are currently investigating reports of SMS delivery issues on all of our deployments and are working to correct the issue as soon as possible. Please check back here or subscribe to updates for any changes.
Posted May 28, 2021 - 11:21 EDT
This incident affected: DUO51 (SMS Message Delivery), DUO52 (SMS Message Delivery), DUO39 (SMS Message Delivery), DUO47 (SMS Message Delivery), DUO22 (SMS Message Delivery), DUO17 (SMS Message Delivery), DUO53 (SMS Message Delivery), DUO45 (SMS Message Delivery), DUO42 (SMS Message Delivery), DUO31 (SMS Message Delivery), DUO62 (SMS Message Delivery), DUO4 (SMS Message Delivery), DUO54 (SMS Message Delivery), DUO11 (SMS Message Delivery), DUO38 (SMS Message Delivery), DUO34 (SMS Message Delivery), DUO19 (SMS Message Delivery), DUO48 (SMS Message Delivery), DUO55 (SMS Message Delivery), DUO9 (SMS Message Delivery), DUO63 (SMS Message Delivery), DUO14 (SMS Message Delivery), DUO30 (SMS Message Delivery), DUO26 (SMS Message Delivery), DUO29 (SMS Message Delivery), DUO44 (SMS Message Delivery), DUO12 (SMS Message Delivery), DUO64 (SMS Message Delivery), DUO25 (SMS Message Delivery), DUO65 (SMS Message Delivery), DUO66 (SMS Message Delivery), DUO46 (SMS Message Delivery), DUO60 (SMS Message Delivery), DUO27 (SMS Message Delivery), DUO3 (SMS Message Delivery), DUO50 (SMS Message Delivery), DUO8 (SMS Message Delivery), DUO40 (SMS Message Delivery), DUO58 (SMS Message Delivery), DUO43 (SMS Message Delivery), DUO32 (SMS Message Delivery), DUO24 (SMS Message Delivery), DUO2 (SMS Message Delivery), DUO28 (SMS Message Delivery), DUO5 (SMS Message Delivery), DUO16 (SMS Message Delivery), DUO41 (SMS Message Delivery), DUO6 (SMS Message Delivery), DUO13 (SMS Message Delivery), DUO18 (SMS Message Delivery), DUO37 (SMS Message Delivery), DUO20 (SMS Message Delivery), DUO7 (SMS Message Delivery), DUO15 (SMS Message Delivery), DUO49 (SMS Message Delivery), DUO56 (SMS Message Delivery), DUO61 (SMS Message Delivery), DUO59 (SMS Message Delivery), DUO1 (SMS Message Delivery), DUO33 (SMS Message Delivery), DUO36 (SMS Message Delivery), DUO23 (SMS Message Delivery), DUO10 (SMS Message Delivery), DUO57 (SMS Message Delivery), DUO21 (SMS Message Delivery), and DUO35 (SMS Message Delivery).